Windows Server 2019: Remote Desktop License Issue with User CALs

If you’re getting the following error message upon connecting to your Windows Server 2019-based Remote Desktop Session Host that is not joined to a domain:

There is a problem with your Remote Desktop license, and your session will be disconnected in 60 minutes. Contact your system administrator to fix this problem.

…I’ve bad news for you: in Windows Server 2019 environment, User CALs require AD. If you insist on using RDS without AD, apparently you’ve to get Device CALs or downgrade to Windows Server 2016 or earlier (also: deleting the L$RTMTIMEBOMB registry key probably won’t help).

As Microsoft states, “CALs cannot be tracked within a workgroup” (yeah, right!). See also: Problem with Windows Server 2019 RDS License (Microsoft TechNet).

This entry was posted in Journal and tagged . Bookmark the permalink.

18 Responses to Windows Server 2019: Remote Desktop License Issue with User CALs

  1. Katia Cooper says:

    Got the same problem since the launch of 2019. Hope Microsoft will fix this soon..

  2. Mike Zarei says:

    We have the same issue with Window Server 2019 and User CAL license. Any update on this?

  3. James Cook says:

    This is really annoying. This happened to us since the working from home due to COVID-19. I had to set this server up, had a bunch of fighting with my accounting department and eventually got them to acquiesce to the fact that this was the right way to go about things, and then this happens. I had to restart for a Quickbooks update and then this started happening. I clearly have licenses available, but the server just doesn’t care.

  4. James Cook says:

    That last comment was all over the place… but yes. It’s causing me a lot of headache with a department that I butt heads with a lot.

    I’d hope there’s some sort of fix to this by now. This can’t be right. Charging people so much money for the server license, plus the cost of the CALs, only to have this server try to force you to adding it to a domain, which we don’t have anymore. I don’t want to be forced in to creating another one, but it looks like that might be my only fix…

  5. Lo Fui Sing says:

    I have seen the same problem after change my server IPV 4 address. All the RDS users will see the “60minutes”warning message, while the Admins donnt.
    Then change server IP address to previous IP address, “60 minutes” warning gone.

  6. alsko says:

    I really don’t understand what is annoying or frustrating. Windows 2019 will not allow Terminal Services to work with per User licensing mode and CALs if it’s not in a domain environment. If an admin needs to leave the server on a workgroup environment for whatever reason, they can only use per device CALs and licensing mode. As simple as that. It’s not broken nor does it need a fix. It is what it is. Earlier versions would allow it but could not track down licensing usage so an admin could overallocate by mistake and face legal issues due to not honoring the license agreement. This overallocating possibility is now fixed so no-one has to worry about not honoring the agreement.

    • Geert-Jan Siebert says:

      Why it is annoying and frustrating? For example that your connection is broken after 60 minutes? I use the non-domain server to manage our cash-devices in our shops. They are NOT member of any domain for obvious reasons.

  7. David says:

    It should be mentioned that it’s now possible to convert your CALs from per-user to per-device on the fly within RD License Manager. Simply right-click the ones you want to convert and select Convert Licenses. It’ll even allow you to convert a subset of them or all.

  8. abenites says:

    Hi!

    Please try the following to activate the license server. It is currently not activated automatically and the following steps are needed.

    Launch Local Group Policy Editor (gpedit.msc)
    In the left pane, navigate to Local Computer Policy->Computer Configuration->Administrative Templates->Windows Components->Remote Desktop Services->Remote Desktop Session Host->Licensing
    In the right pane, right click Use the specified Remote Desktop license servers and select Edit
    In the group policy editor dialog, select Enabled
    Enter the local computer name in the License servers to use: field.
    Select OK
    In the right pane, right click Set the Remote Desktop licensing mode and select Edit
    In the grou policy editor dialog, select Enabled
    Set the Licensing mode to Per Device/Per User
    Select OK

    Once the Licensing mode on the RDSH role is configured properly, the notification about the grace period goes away.

  9. Pari says:

    I am using WS 2019, I am in Work Group Mode. I have the Licenses set to Per Device, as many people have mentioned that Per User will NOT work.

    Anyway, I am getting this same 60 minute error, so clearly there is some issue, assuming it to be a Microsoft bug?

  10. Keith says:

    We have a domain environment using per user licensing and are also getting the same error. These were 2012 R2 Licensing Servers (that worked just fine as 2012) that were upgraded to Server 2019 R2, licenses converted to 2019 Licenses (still per user), and then the servers were re-activated. Done a ton of troubleshooting and even have an active Microsoft support case open, and still no resolution. This shows that the issue goes beyond dropping support for non-domain environments as these are a part of a domain. If anyone has any other ideas or solutions for someone using it the “proper” way (on a domain) please let me know. In the meantime hopefully this Microsoft support case will prompt them to fix this bug.

  11. Don says:

    12-6-20 getting same error, this is how I fixed (if using AD):
    – make sure ipv6 is enabled, reboot, then run gpresult /r
    I noticed my remote desktop policy was not being applied and local policy was being filtered out. This means it was not getting licensing from AD.
    I added the licensing info to the default domain policy (only one that ever really seems to work in a mixed environment) and it resolved the issue.

  12. Oscar Gomez says:

    Just Try to convert to Device Cal, thats works for me.
    Windows Server 2019 under Domain
    Windows Server 2016 Too

  13. Ezra Keppler says:

    i have the same issue, on a workgroup in Server 2016 and configured as per device, i even though of upgrading since it does not is the same on Server 2019. may we kindly have a solution.

  14. Jun says:

    I got the same error message after I installed windows server 2019 recently. The system was activated and I also installed both licenses for per user cal and per device cal via activate.microsoft.com. In addition, our server was in an AD. I’ve tried both per user and per device mode in local group policy but the problem is not solved and the error message still pops up every time I login remotely with a domain user ID. Can anyone help?

Leave a Reply to Mike Zarei Cancel reply

Your email address will not be published. Required fields are marked *